Microsoft's fix has been applied to 97% of tenants and 40% of previously affected mailboxes have been restored. Less than 100 Front mailboxes are currently affected. While Microsoft is actively rolling out the fix to all mailboxes, the exact timeline for all mailboxes to be restored is unknown. For further assistance on this issue, please work directly with support@front.com.
Posted May 08, 2025 - 18:24 UTC
Identified
Microsoft has identified the root cause of this issue as a code change deployed on Wednesday, April 23. They have deployed a fix to prevent the scope of this issue from expanding and are working on a separate fix to repair all affected mailboxes. We will update you when we have more information.
Posted May 02, 2025 - 21:25 UTC
Update
A small number of Office365 channels are not delivering messages to Front due to an issue inside Microsoft infrastructure. Please contact Microsoft for assistance with an affected mailbox.