[Partner] [office365] Slow imports for messages

Incident Report for Front's Partners Status

Resolved

The incident has been resolved.
Posted Jun 16, 2025 - 23:41 UTC

Monitoring

We are monitoring full service after partner incident has been resolved.
Posted Jun 16, 2025 - 23:23 UTC

Investigating

We are monitoring our partner's outage and will update as we learn more.
Posted Jun 16, 2025 - 23:13 UTC